iPhone stuck on synchronization

First time using the app and it gets stuck on synchronization. I have reinstalled the app restarted my phone reset the Bluetooth with no luck. Would be nice to get a fix or solution. Thanks!


Hi Brandon, sorry about that! Can you please tell me what model iPhone you have? That way our engineers can debug this issue.

And in the meantime, please download the legacy version of our App while we figure this problem out.

Also you can try powering on the EKGraph right after pressing the Sync button in the app and see if that helps.

Here’s photos of the previous message from I believe the previous buyer “Brandon”, who returned this defective SonoHealth EKG heart monitor.
I believe Amazon took this defective monitor back repackaged it and sold it as NEW to me !!!
I also found previous scans from June & July which must belong to “Brandon” !!!
Since I just bought this Supposedly New SonoHealth EKG heart monitor in September, there shouldn’t have been any previous heart scans on this monitor !
This ekg monitor definitely has a defect so I’m going to return it to Amazon. Hopefully someone with scruples and a conscious won’t try to repackage it again and re-sell it to another unsuspecting Amazon buyer !!!

1 Like

I am experiencing the same issue on iPhone X iOS 15.0.1. I downloaded the original version instead of the 2.0 so I can offload my data

I am also having the same issue with iPhone X.

I am also having the same issue on the iPhone X.

1 Like

I’m experiencing the same thing with an iPhone 11 Pro Max. I have both the EKGraph and Pulse Oximeter units.

In my case, the Sonohealth unit synced just fine with the original Sonohealth app, but cannot sync with Sonohealth 2.0. What happens is that I see exactly what you see above, and the EKG unit flashes a sign saying to hold 3 seconds to cancel. I wait, and instead of synchronizing, the app goes back to message 2/3, saying to turn on the unit. Of course, the unit is already on.

Even worse, the Sonohealth 2.0 app cannot connect at all with my brand new Sonohealth pulse oximeter. If the bluetooth app does not work, this oximeter is essentially identical to one I bought in Canada for half the price.

I have to say, so far this is the worst experience I’ve ever had with a new electronic device company.

Have the same issue where old App sync’ed but wanted new App so that data would sync with other Health Apps. Tried deleting old App but still doesn’t work. I have the IPhone 12.

I have the 99 recordings that you can have on my ECG and with a new iPhone 13 Pro it keeps timing out. I get about 50 recordings uploaded and then it times out. I sit there, fastidiously, and press the button to make sure that it stays awake but it still times out. Any suggestions

I have an iPhone 13 and it times out when synchronizing after 2 or 3 readings. Then after synchronizing the readings don’t appear on the list.

I have the iPhone SE with 2.0 version and same thing happens. Tried reboot, reinstall …nothing. Can’t get old app, not avail in App Store

After u do all that, take another reading and it’ll sync then, took me forever to figure out